-
Notifications
You must be signed in to change notification settings - Fork 51
/
Copy pathBalikavadhu.cpp
264 lines (204 loc) · 5.25 KB
/
Balikavadhu.cpp
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
/*
Name: Gourav Singh
https://www.linkedin.com/in/gouravsingh2580/
*/
/*
Anandi and Jagya were getting married again when they have achieved proper age. Dadi Sa invited
Alok Nath to do the kanyadaan and give blessings. Alok Nath has 2 blessings. Each bessing is in
the form of a string consisting of lowercase charaters(a-z) only. But he can give only one
blessing of K length because some priest told him to do so. Thus he decides to generate a
blessing using the other two blessings. While doing this he wants to ensure that happiness
brought into their life by his blessing is maximum.
The generated blessing is a common subsequence of length K of the two blessings he has. Happiness
of the blessing he generates is calculated by the sum of ASCII values of characters in the blessing
and he wants the happiness to be maximum. If he is not able to generate a common subsequence
of length K then the happiness is 0 (zero). Alok Nath comes to you and asks you to find the maximum
happiness that can be generated by the two blessings he has.
Input Specification
First line consists of number of test cases t. Each test case consists of two strings b1 (blessing 1),
b2 (blessing 2) and an integer K, each of them in separate lines.
Output Specification
Output consists of t lines each containing an integer denoting the maximum happiness value
that can be generated by the two blessings.
Constraint
1 <= t <= 50
1 <= length(b1) , length(b2) <= 100
1 <= K <= 100
Sample Input
2
asdf
asdf
3
anandi
jagya
3
Sample Output
317
0
*/
/*
RECURSIVE SOLUTION WITHOUT DP
int go(string s1, string s2, int k, int i, int j){
int l1 = s1.size()-i;
int l2 = s2.size()-j;
//Recursive solution
if(k>l1 || k>l2){
return 0;
}
if(k<=0){
return 0;
}
if (s1[i] == s2[j])
{
//I include the eqaul character
int go1 = s1[i] + go(s1, s2, k-1, i+1, j+1);
//If function fails to bring enough characters for i+1, j+1
if (go(s1, s2, k-1, i+1, j+1) == 0 && k>1)
{
go1 = 0;
}
//I do not include the equal character
int go2 = go(s1, s2, k, i+1, j+1) ;
//Alternatively include them
int go3 = go(s1, s2, k, i+1, j) ;
int go4 = go(s1, s2, k, i, j+1) ;
return max(go1,max(go2,max(go3,go4)));
}else{
//Alternatively include them
int go3 = go(s1, s2, k, i+1, j) ;
int go4 = go(s1, s2, k, i, j+1) ;
return max(go3,go4);
}
}*/
/*
MEMOIZATION SOLUTION
#include <bits/stdc++.h>
using namespace std;
int maxHappiness(string s1,string s2,int k,int output[][101][101]){
if(k==0){
return 0;
}
if(s1.size()==0 || s2.size()==0)
return INT_MIN;
if(output[s1.size()][s2.size()][k]!=-1)
return output[s1.size()][s2.size()][k];
if(s1[0]==s2[0]){
int option1=maxHappiness(s1.substr(1),s2.substr(1),k-1,output)+s1[0];
int option2=maxHappiness(s1,s2.substr(1),k,output);
int option3=maxHappiness(s1.substr(1),s2,k,output);
int ans=max(option1,max(option2,option3));
output[s1.size()][s2.size()][k]=ans;
return ans;
}
else{
int option1=maxHappiness(s1.substr(1),s2,k,output);
int option2=maxHappiness(s1,s2.substr(1),k,output);
int ans=max(option1,option2);
output[s1.size()][s2.size()][k]=ans;
return output[s1.size()][s2.size()][k];
}
}
int main()
{
int t;
cin>>t;
while(t--){
string s1,s2;
cin>>s1>>s2;
int k;
cin>>k;
int output[101][101][101];
memset(output,-1,101*101*101*sizeof(int));
int ans=maxHappiness(s1,s2,k,output);
if(ans<0)
cout<<"0"<<endl;
else
cout<<ans<<endl;
}
return 0;
}
*/
//DP SOULUTION
#include <bits/stdc++.h>
using namespace std;
int go(string s1, string s2, int k){
int m = s1.size();
int n = s2.size();
int dp[m+1][n+1][k+1];
memset(dp, -1, sizeof(dp));
for (int i = 0; i < m+1; ++i)
{
for (int j = 0; j < n+1; ++j)
{
dp[i][j][0] = 0;
}
}
//starting from n(out of string) in second string
for (int i = 0; i < m+1; ++i)
{
for (int p = 0; p < k+1; ++p)
{
dp[i][n][p] = 0;
}
}
//starting from m(out of string) in first string
for (int i = 0; i < n+1; ++i)
{
for (int p = 0; p < k+1; ++p)
{
dp[m][i][p] = 0;
}
}
for (int i = m-1; i >= 0; --i)
{
for (int j = n-1; j >= 0; --j)
{
for (int p = 1; p < k+1; ++p)
{
if(s1[i] == s2[j]){
if (p>m-i || p>n-j)
{
dp[i][j][p] = 0;
continue;
}
int go1 = int(s1[i]) + dp[i+1][j+1][p-1];
//If function fails to bring enough characters for i+1, j+1
if (dp[i+1][j+1][p-1] == 0 && p>1)
{
go1 = 0;
}
//I do not include the equal character
int go2 = dp[i+1][j+1][p] ;
//Alternatively include them
int go3 = dp[i+1][j][p] ;
int go4 = dp[i][j+1][p] ;
dp[i][j][p] = max(go1,max(go2,max(go3,go4)));
}else{
if (p>m-i || p>n-j)
{
dp[i][j][p] = 0;
continue;
}
int go3 = dp[i+1][j][p] ;
int go4 = dp[i][j+1][p] ;
dp[i][j][p] = max(go3,go4);
}
}
}
}
return dp[0][0][k];
}
int main( int argc , char ** argv )
{
ios_base::sync_with_stdio(false) ;
cin.tie(NULL) ;
int n;
cin>>n;
while(n--){
string s1, s2;
int k;
cin>>s1>>s2>>k;
cout << go(s1, s2, k) << '\n';
}
return 0 ;
}